Search found 6 matches

by MathiasJ
Tue Jun 02, 2020 8:44 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

Re: FBX displays material in viewport but not in render

Cheers :) I'll be sure to recommend MOPs to others.
by MathiasJ
Tue Jun 02, 2020 8:39 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

Re: FBX displays material in viewport but not in render

Right, that makes sense.
What do you think I should search for, for that stylesheet technique?
I've used them before to apply a default shader to all objects for lighting scenes but not like this.
by MathiasJ
Tue Jun 02, 2020 8:31 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

Re: FBX displays material in viewport but not in render

I got it working! You were right about Declare Materials. Houdini just didn't cook it, so I had to disable/enable the node and the textures are there now :) You have no idea how relieved and happy that made me hah. Thanks!
by MathiasJ
Tue Jun 02, 2020 8:25 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

Re: FBX displays material in viewport but not in render

Attached an image to make sure I got the right option?
I tried setting it to 'Save All Materials and Shaders.' Didn't work sadly.
by MathiasJ
Tue Jun 02, 2020 8:13 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

Re: FBX displays material in viewport but not in render

Heya. Thanks for the reply. Tried attaching a simple HIP file to show you but it was too big to upload. I import the FBX into a Geometry node, then setup Principled Shaders pointing to texture maps and use the shop_materialpath to apply materials to primitives using the Material node and wire it int...
by MathiasJ
Tue Jun 02, 2020 6:36 am
Forum: Bug Reports
Topic: FBX displays material in viewport but not in render
Replies: 9
Views: 503

FBX displays material in viewport but not in render

Just started using this great tool and it has made my instancing so much easier. Thanks! Ran into an issue when instancing FBX files with UV textures though (e.g. Megascans plants, rocks etc.) which I've tried to fix for a few hours now with no luck. The material displays in the viewport after insta...