Issue using two spring modifiers

Ask questions about how to achieve specific effects, how to work with certain operators, etc.
Post Reply
gsedory99
Posts: 4
Joined: Mon Mar 07, 2022 8:11 am

Issue using two spring modifiers

Post by gsedory99 »

Hi,

I'm trying to use two spring modifiers. The first one is on a scale transform modifier and then later on in the node tree I have a second falloff and a rotation transform modifier. When I try to add a spring modifier after that to modify the rotation, the scene gets all wacky and does things I'm unable to explain. I tried deleting all the attributes that the previous MOPs nodes created before adding the falloff, transform and spring modifiers the second time but that didn't seem to work either. Any thoughts would be great. Really appreciate the help.

User avatar
toadstorm
Site Admin
Posts: 120
Joined: Sun Sep 22, 2019 1:28 pm

Re: Issue using two spring modifiers

Post by toadstorm »

Any chance you could post a quick hip file that demonstrates the problem?

gsedory99
Posts: 4
Joined: Mon Mar 07, 2022 8:11 am

Re: Issue using two spring modifiers

Post by gsedory99 »

Sure this is a quick simple example. Just adding a second falloff as mops_falloff2 and a transform modifier for rotation to utilize it. Then I want to modify that second animation with a spring modifier and I'm having trouble doing that.

Thanks!

https://we.tl/t-joivxYWmnF

gsedory99
Posts: 4
Joined: Mon Mar 07, 2022 8:11 am

Re: Issue using two spring modifiers

Post by gsedory99 »

Sorry the link didn't work there, here is the hip file.
You do not have the required permissions to view the files attached to this post.

User avatar
toadstorm
Site Admin
Posts: 120
Joined: Sun Sep 22, 2019 1:28 pm

Re: Issue using two spring modifiers

Post by toadstorm »

The Spring Modifier is freaking out in this case because on the first frame of the simulation, there aren't any objects due to the Blast SOP deleting all points greater than the falloff threshold. If you move that Blast to after the second Spring Modifier, the scene should work normally.

Spring Modifier internally is using a Solver SOP, which means its conditions are locked on the first frame of simulation... it's not adding new objects over time. It's something I can look into to see if it's possible to merge in new objects over time. If I can get it working without too much of a performance hit, I'll add it to a future release.

gsedory99
Posts: 4
Joined: Mon Mar 07, 2022 8:11 am

Re: Issue using two spring modifiers

Post by gsedory99 »

awesome! Thanks for the help with this. You are a genius. Truly love what you're doing with this. Primarily C4D user here and I'm working hard to try and see if I can do most of my C4D Mograph-like work through houdini+MOPs. This helps a lot.

User avatar
toadstorm
Site Admin
Posts: 120
Joined: Sun Sep 22, 2019 1:28 pm

Re: Issue using two spring modifiers

Post by toadstorm »

Happy to help! If you have any other comments or suggestions about MOPs, feel free to reach out to me here, by email, or on the MOPs Discord.

Post Reply