problem with using a Mops instances

Ask questions about how to achieve specific effects, how to work with certain operators, etc.
Post Reply
AndreAndre_1986
Posts: 31
Joined: Sun Jan 19, 2020 1:07 am

problem with using a Mops instances

Post by AndreAndre_1986 »

New folder.rar
example scene

I have a problem with using a Mops instances, the fact is that I want to use a texture but it does not read the vertex coordinates, I have to convert to points and do a vertex split, which distorts and breaks the topology. further if I want to unpack(for editing) the uv geometry, it is erased altogether uv.
In general, now the MOPs is not suitable for textured models, unfortunately
2020-07-20_080211.jpg
2020-07-20_082728.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
toadstorm
Site Admin
Posts: 58
Joined: Sun Sep 22, 2019 1:28 pm

Re: problem with using a Mops instances

Post by toadstorm »

Packed geometry in MOPs is no different from packed geometry anywhere else in Houdini. If your objects have vertex UVs prior to being packed (or input into the Instancer), those UVs remain embedded in the geometry. They will not be directly accessible to you without unpacking, but the render engine will still use packed UVs as texture coordinates.

I'll take a look at the scene tomorrow and see what's going wrong, but I have a feeling it's not specific to MOPs.

AndreAndre_1986
Posts: 31
Joined: Sun Jan 19, 2020 1:07 am

Re: problem with using a Mops instances

Post by AndreAndre_1986 »

i think is not specific MOPS, but intresting to use textured instances for MOPS

AndreAndre_1986
Posts: 31
Joined: Sun Jan 19, 2020 1:07 am

Re: problem with using a Mops instances

Post by AndreAndre_1986 »

sorry.I figured it out.all ok !!!!!!!!!!
You do not have the required permissions to view the files attached to this post.
Last edited by AndreAndre_1986 on Mon Jul 20, 2020 10:56 am, edited 1 time in total.

User avatar
toadstorm
Site Admin
Posts: 58
Joined: Sun Sep 22, 2019 1:28 pm

Re: problem with using a Mops instances

Post by toadstorm »

In your example file, the problem is that in the Unpack SOP you're transferring "UV" from the packed geometry to the unpacked geometry, which mangles your original UVs. Just leave the UVs as vertex attributes before the Instancer, then when you're done with the MOPs stuff, unpack using the default options (don't transfer UVs). Your UVs should remain exactly as they were.

AndreAndre_1986
Posts: 31
Joined: Sun Jan 19, 2020 1:07 am

Re: problem with using a Mops instances

Post by AndreAndre_1986 »

"problem with using a Mops instances" is solved
thanks toadstorm!

Post Reply